当前位置:首页-正文

谷歌针对不兼容Microsoft Edge发布声明:那是微软自己的锅

日前有用户发现谷歌旗下的 Google Meet 视频会议服务无法使用微软新版本的Microsoft Edge浏览器访问。

当用户访问时会出现兼容性提示并指导用户下载谷歌浏览器或者火狐浏览器,看起来这是存在着兼容性问题。

但是Microsoft Edge本身是基于Chromium开发的,其实和谷歌浏览器没有太大区别又怎么会出现不兼容呢?

这不得不让人怀疑是不是谷歌又开始恶作剧故意进行不兼容,然后诱导用户下载使用谷歌自己的浏览器产品。

谷歌针对不兼容Microsoft Edge发布声明:那是微软自己的锅-第1张

谷歌发布声明表示这是微软自己的锅:

谷歌发言人表示该公司不仅没有故意不兼容Microsoft Edge浏览器,反而是将该浏览器加入此服务的白名单。

因此正常情况下Microsoft Edge是绝对不会与该服务存在兼容问题的,所以这并不是谷歌故意进行不兼容的。

相反Microsoft Edge内置智能用户代理字符串切换工具,有时候会根据不同的网站切换字符串获得最佳体验。

不幸的是微软将 Google Meet 加入智能切换列表使用EdgeHTML代理,这才是导致出现不兼容提示的原因。

尚不清楚微软这个做法是为什么:

智能切换用户代理字符串是微软根据不同网站作出的适配,因为不同内核对于不同网站的性能表现会有差异。

例如在奈飞视频网站上使用微软自己的代理字符串性能会更好些,所以用户访问时浏览器会自动进行切换等。

但是Google Meet这类服务肯定优先兼容自家的Chromium内核,所以不清楚微软为何也将其加入切换列表。

感谢您的阅读,若本文未注明来源其他网站则版权归蓝点网所有,若已注明来源则版权归源站所有,转载时请注明蓝点网和/或源站链接。